切换语言: English Русский Українська

模组开发

From Official Factorio Wiki
Jump to: navigation, search

本页面将会带领您了解如何下载和安装mod,并且为方便您创建一个mod时所需而提供了一个和mod开发相关的概述。有关更详细的mod开发说明,您可以查看 mod开发教程.如果您正在查找mod开发所需的相关API,请前往官方 Factorio Lua API 文档(注意,该文档为英文)查看。如果您希望知道在哪里安装zip格式的mod,请查看应用程序目录

Mod 下载 & 安装

您可以在以下链接下载MOD:

Mod门户站 (网页版)

Factorio的开发者创建论坛版块 mod门户站 (网页版) 使玩家可以分享各自制作的mod。 注意,从论坛下载的mod是zip格式,为了安装mod你需要将zip文件复制到 user data directory 并且不需要解压缩它。 你可以在游戏主菜单查看mod列表中是否存在该mod来检查你是否正确安装该mod。

Mod门户站 (游戏内)

在网页 mod门户站 (网页版) 上的mod你可以在游戏内主菜单的mod下载页面查看。 游戏内置的mod下载与网页下载的不同主要在于它可以自动的下载与安装,并且可以随时启用和停用mod(网页版下载的也可以随时启用和停用!)。

论坛Mod板块

某些mod制作者将他们的mod上传到官方论坛子板块论坛Mod板块来展示而没有提交至mod门户站,或者 想在更新发布之前获取交流反馈。这类mod被作为附件上传。有时,你从论坛下载的mod同样使用了zip格式,你仅仅需要将它复制到user data directory就表示安装完成了,不需要解压缩。你可以在游戏主菜单查看mod列表中是否存在该mod来检查你是否正确安装该mod。

Mod依赖

大多数的mod使用了factorio的base mod(包含全部官方内容的mod)。然而有些mod也可能会必须依赖于其他mod或者在其他可选依赖的mod安装之后可以提供额外功能。

必须依赖

当你安装一个mod时,它必须依赖于某个另外的mod才能工作,这种mod就被叫做必须依赖。

可选依赖

当一个mod建议你安装另一个mod并且在不安装被建议的mod也能工作时,这种mod即为可选依赖。

注意

当前的游戏内置mod下载平台不会下载任何依赖mod,因此那些依赖的mod需要玩家手动下载。然而这个功能在将来会被实现(该功能以及被提上日程)。

开始开发一款Mod

另请参见: Tutorial:Modding

API 文档

Lua 脚本

你需要使用 Lua(版本: 5.2.1) 编程语言来制作 Factorio 的任意Mod。 游戏的Mod系统将会把你的代码在游戏启动和数据构建阶段注入游戏。 你可以使用任意文本编辑器来编辑你的Mod。 已知为 Lua 提供代码提示以及高亮的编辑器有 Notepad++Sublime Text

有用的 Lua 资源:

Mod的基本结构

Factorio 的Mod是一个Zip格式的文件,里面包含了 Factorio 在加载Mod时会查找的几个重要文件。下面列出了这些文件,必需得文件显示为红色字体

  • ExampleMod_0.0.1.zip
    • info.json
    • control.lua
    • data.lua
    • data-updates.lua
    • data-final-fixes.lua

授权信息

随着v0.11版本的到来所有mod需要有一个许可类型。 如果一个MOD没有指定许可类型,将使用默认的 Attribution-NonCommercial 4.0 International (CC BY-NC 4.0)。然而,可以有目的地使Mod使用unlicensed 协议,使代码可以被公共域修改及分发。Factorio Mod最受欢迎的分发许可证为 MIT licenseGPLv3 license.

其他有用的法律链接包括:

另请参见